Thread: Fuel problems

Results 1 to 11 of 11
  1. #1
    Member
    Join Date
    Jul 2008
    Location
    Louisiana
    Posts
    33

    Fuel problems

    Ran my fx about 15 miles up the lake this morning made 2 short moves and when I went to move again the SHO cut out and died would start up again but wouldn't run long. Checked the fuel bulb and it didnt have any pressure was running on dual after switching the tanks back and fourth from port to starboard the port tank is not pulling any fuel am the starboard tank is just fine. Any suggestions guys?

  2.  
  3. Member
    Join Date
    Jun 2004
    Location
    Apex, NC
    Posts
    2,726
    #2
    Check for a kink in the fuel line from port tank. There could also be a problem with the selector valve or the pick tube in the tank. In older skeeters there is a check valve at the elbow fitting going into the tank, not sure about the fx but that can also restrict fuel if that check valve is stuck. Interesting that I heard this before from a couple of PRO anglers having this problem but not sure what the fix was.
    Rich Z, USAF Ret.
    BRUCATOsvs.com More Power To You

  4. GJG
    GJG is offline
    Member
    Join Date
    Oct 2012
    Location
    SETX
    Posts
    143
    #3
    i have an '11 zx250 which has started to exhibit the same problem. I was told by an X yamaha mechanic that when he worked at the skeeter dealership they "knocked" the ball out of the check valve to cure the problem. Has anyone else had this problem......what was your fix?

    My main question is.....what is the purpose of the "check valve"????.....and if i can disable the check valve and fix the fuel starvation problem what issues does not having the check valve create???????

  5. Member
    Join Date
    Mar 2013
    Location
    louisiana
    Posts
    11
    #4
    Replace the bulb. Should fix it right up

  6. GJG
    GJG is offline
    Member
    Join Date
    Oct 2012
    Location
    SETX
    Posts
    143
    #5
    Quote Originally Posted by blackbullet2.4ltr View Post
    Replace the bulb. Should fix it right up
    don't think that's the problem.....anti siphon valve is, as the mechanic said, a common issue.

  7. GJG
    GJG is offline
    Member
    Join Date
    Oct 2012
    Location
    SETX
    Posts
    143
    #6
    anyone?

    anyone know the mechanics of removing the elbow fitting on top of the tank? will it just unscrew from the flange fitting on top of the tank?

  8. Member
    Join Date
    Jun 2004
    Location
    Apex, NC
    Posts
    2,726
    #7
    Yes, it should just unscrew. I removed one before but that was on an 02 ZX model. Not sure if its the same on FX. Im too having uneven fuel pull from tanks on a 12 FX. It seems to be a common problem. Sometimes it could be as much as 5gl difference and other times its even. I keep an eye on my fuel gauges all the time. If it continues to be a problem a further investigation is on my list of to do things that seem to get longer with every outing. So far Im not impressed with the fx at all.
    Rich Z, USAF Ret.
    BRUCATOsvs.com More Power To You

  9. GJG
    GJG is offline
    Member
    Join Date
    Oct 2012
    Location
    SETX
    Posts
    143
    #8
    another possibility on the fuel starvation......when i was checking the fuel lines, the line OUT of the dual tanks valve to the engine seems really soft not stiff like the fuel lines from the tanks to the valve. i would assume that this line is rigged by skeeter but i am wondering if it's possible if it is collapsing under suction from the fuel pump?

  10. Member
    Join Date
    Aug 2010
    Location
    Potter County
    Posts
    65
    #9
    Quote Originally Posted by Pipeliner View Post
    Ran my fx about 15 miles up the lake this morning made 2 short moves and when I went to move again the SHO cut out and died would start up again but wouldn't run long. Checked the fuel bulb and it didnt have any pressure was running on dual after switching the tanks back and fourth from port to starboard the port tank is not pulling any fuel am the starboard tank is just fine. Any suggestions guys?
    3 year component warranty from Skeeter. It sounds like the selector valve which would be replaced under warranty.

  11. GJG
    GJG is offline
    Member
    Join Date
    Oct 2012
    Location
    SETX
    Posts
    143
    #10
    Quote Originally Posted by flyfishingrules View Post
    3 year component warranty from Skeeter. It sounds like the selector valve which would be replaced under warranty.
    what he is describing is a faulty anti syphoon valve.....

    the selector valve is a brass valve that i don't think can cause the problem....it might leak like a water faucet but it is either open to 1 tank or the other or both.....unless the operator stops turning between positions it cannot obstruct flow.........

  12. GJG
    GJG is offline
    Member
    Join Date
    Oct 2012
    Location
    SETX
    Posts
    143
    #11
    found the issue....throttle cable was out of it's holding bracket at he engine....