Page 1 of 2 12 LastLast
Results 1 to 20 of 23
  1. #1
    Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411

    Remote Drain Plug Issues

    All,

    I picked up my brand new 2019 Falcon 195 (Oct 2018), came with the remote drain plug. Since the 1st day in the water (breaking in engine) to the 1st tourny fished this past weekend (Nov 2018, 3 days of leaking constantly), it has been leaking non stop. My auto bilge has to come on every 10-20 mins to pump water out. This is UNACCEPTABLE. I called the dealer Fri while I was on the water, they said put some vasoline on the o-ring , etc.. I did. No luck.. Keeps leaking. I informed them as to status.. Waiting to hear back to see how this will be resolved. me personally, I am not sure this remote plug is better that the old school screw in. I had my Triton for 17 years (screw in plug).. Never a problem.

    Has any other Falcon owner had any issues? I know other boat owners have. What were you results, etc..

    Thanks



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  2.  
  3. Member
    Join Date
    Mar 2014
    Location
    Unionville, NC
    Posts
    5,869
    #2
    Are you sure the water is coming in via the plug?

    Also, are you closing it all the way? It'll "click" when fully seated.
    Dave Graham2014 Triton 18XS w/ Merc 150 ProXS

  4. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #3
    Quote Originally Posted by Riccochet View Post
    Are you sure the water is coming in via the plug?

    Also, are you closing it all the way? It'll "click" when fully seated.
    Yes,I looked to confirm, even ws told to open while on water by dealer, water gushed, then closed it, water still seeping in I feel the click, even pushed against it while on trailer to confirm, cannot go any further in.



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  5. Member
    Join Date
    Nov 2012
    Location
    Nederland, Tx
    Posts
    10,582
    #4
    Is it the plug or the housing? If they didnt seal the housing right it could be leaking by

  6. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #5
    Quote Originally Posted by kry29 View Post
    Is it the plug or the housing? If they didnt seal the housing right it could be leaking by

    I am not sure, either way, I should never have received the boat this way. QC should have been done to ensure the plug/housing was not leaking and was installed properly. I understand some things cannot be helped, but this should have been avoided.



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  7. Member
    Join Date
    Mar 2014
    Location
    Unionville, NC
    Posts
    5,869
    #6
    while its on the trailer close it, then throw a hose in your bilge. See where it's leaking from.
    Dave Graham2014 Triton 18XS w/ Merc 150 ProXS

  8. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #7
    Quote Originally Posted by Riccochet View Post
    while its on the trailer close it, then throw a hose in your bilge. See where it's leaking from.
    Will try that this week. This problem is new to me, as my 01 Tr186 never had an issue with leaking. Thanks for the info.



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  9. Member
    Join Date
    Mar 2013
    Location
    Lexington, SC
    Posts
    23
    #8
    The remote plugs can be tricky at times, there’s several things that can cause them to seep. I’ve installed several in the past and have one on my current falcon. It’s definitley not a factory issue.

    You could have a pinched O-ring, or the cable could need a slight adjustment. I’ve had mine leak a couple times in the past few months and opened it, reclosed it on the water to reseal it. Check the oring, and check to make sure it’s making a tight seal while on the trailer.
    '17 Falcon F205
    '17 Evinrude G2 250
    10' PP blades
    Garmin 7610XSV's

  10. Member
    Join Date
    May 2012
    Location
    Castaic, CA
    Posts
    97
    #9
    Mine leaks. When i first got it it was very bad. Now I push it closed on thr trailer and it is a lot better but it does still leak. I am considering removing it and using a normal plug but that leaves the issue of the open hole where the open/close valve was located. It is a good idea that is far prom perfect. My bilge comes on every few hours and I have so far just accepted that.

  11. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #10
    All,
    After a lil troubleshooting, (pouring big bowl of water in rear transom) I was able to determine where the leak was at. It is the leaking on the bottom of the main housing that attaches to the hull. Either they didnt install the gasket or failed to properly seal the main housing to the hull correctly. This is a factory problem, as this should have been caught and fixed during the QC process. I should never have received the boat in this condition. Yes, some people may think this is a small issue, but it is a quality control issue as well. I paid a lot of money for this boat, I expect things like this to be resolved before I get the boat. What if the auto bilge wasn't working properly when i was fishing this past weekend with water temps in the low 50s. The boat would have kept taking on water and maybe I would have been put in a bad situation that could have been prevented. It isn't like this boat is a few years old, I hadn't had this boat a month (picked up in Oct 2018) and first time actually fishing in it. Could have been a lot better and more enjoyable outing without this problem to worry about.

    Waiting on what the dealer says and how to resolve the issue.



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  12. Member
    Join Date
    Nov 2012
    Location
    Nederland, Tx
    Posts
    10,582
    #11
    Easy fix. Take 2 screws out, get some sikaflex 291 and make sure the hole is sealed and get rid of that gasket and use the sika to seal the housing to the boat. Dont be scared to use it liberally. A little acetone on a paper towel can get excess off later after the plug housing is reinstalled. Maybe 30 minute job. Clean the are with acetone before you apply the sealer also. Things happen but I would never trust a gasket on something like that below the water line.

  13. Member
    Join Date
    May 2013
    Location
    Rock Hill Sc
    Posts
    22
    #12
    Have 215 I make sure I keep gasoline on O ring, on mine you have to click it past close setting to get it to seat.

  14. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #13
    Quote Originally Posted by jozmon View Post
    Have 215 I make sure I keep gasoline on O ring, on mine you have to click it past close setting to get it to seat.
    Thanks for tips. I sealed the leak with some silicone, may try the sikaflex 291 and I am waiting on new O ring from Falcon, They are sending me a few extra SO far so good.

    Thanks all



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  15. Member
    Join Date
    Mar 2014
    Location
    Unionville, NC
    Posts
    5,869
    #14
    If that's the only issue with the boat I wouldn't even be upset. My Triton was a clusterf*** of issues. Not that it's excusable, but they are built by humans. Most boats are delivered with something wrong. Having worked at a marine dealer it's hard to catch them all before delivery.
    Dave Graham2014 Triton 18XS w/ Merc 150 ProXS

  16. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #15
    Riccochet,

    I understand they will sometimes have issues, but I would think they have a QC in place.. Also, I had an 01 Triton before this one, I bought it new as well. Never had any issue like this or anything. That was a da.. good boat.



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



  17. Member
    Join Date
    Mar 2014
    Location
    Unionville, NC
    Posts
    5,869
    #16
    Quote Originally Posted by tritonboy2001 View Post
    Riccochet,

    I understand they will sometimes have issues, but I would think they have a QC in place.. Also, I had an 01 Triton before this one, I bought it new as well. Never had any issue like this or anything. That was a da.. good boat.
    I'm sure they do have QC in place. But, like anything else, shit happens. Pick any brand boat, car, anything, and you will find QC issues. You take a risk, like anyone else, when you buy anything that there is the potential for there to be an issue. It's how those issues are dealt with that makes the difference.
    Dave Graham2014 Triton 18XS w/ Merc 150 ProXS

  18. Member
    Join Date
    Jun 2017
    Location
    TN
    Posts
    70
    #17
    In fairness to Falcon after having ate a pound of flesh, sounds like they are taking care of your problem. Apparently, not as good of a boat as your Triton in your opinion. Too bad this issue did not show up when you tested the boat before taking delivery, it could have saved some trouble.

  19. Member
    Join Date
    Apr 2013
    Location
    South Londonderry, Vermont
    Posts
    1,809
    #18
    Mine works perfect, no leaks. My first remote plug. Don't think I would want a boat without one now.

  20. Member
    Join Date
    Apr 2014
    Location
    Xenia, Ohio
    Posts
    5,345
    #19
    Quote Originally Posted by fuelleak View Post
    Mine works perfect, no leaks. My first remote plug. Don't think I would want a boat without one now.

    same here, but need to keep the o-ring lubed up
    2000 stratos 20 ss (bought new)
    200 hp Rude ficht -re200flssh
    twin 12 ft. talons-blue water leds
    hook 7 and lms520c
    pulled by a 2500HD Denali
    bravo1 fs croxtonized
    proud dad of an ARMY Lieutenant. Deployed
    proud uncle of an ARMY Sergeant, deployed
    member of "team deplorable" MAGA

  21. Member tritonboy2001's Avatar
    Join Date
    Nov 2009
    Location
    Milton
    Posts
    411
    #20
    what are you all using to keep the ring lubed?



    Jason Davis, MSgt, USAF, Retired



    IF YOUR NOT GETTING HUNG UP, YOUR NOT FISHING WHERE THE FISH ARE!!"

    2019 Falcon 195
    2019 Yamaha SHO 200 w 23P Fury
    Helix 9 DI (Bow)
    Helix 9 SI with Mega (Console)
    MK Ultrex 80lb
    NMEA 2k



Page 1 of 2 12 LastLast