Thread: squeaky ultrex

Results 1 to 10 of 10
  1. #1
    Banned
    Join Date
    Mar 2011
    Location
    Lake Lanier
    Posts
    19,827

    squeaky ultrex

    anyone know what to lube that joint with?


  2.  
  3. Member
    Join Date
    Jul 2010
    Location
    Phenix city AL
    Posts
    492
    #2
    No but I sure hope someone chimes in with a answer! My ultrex does the same thing and it drives me crazy. Funny you posted this I was just talking about it yesterday at the boat ramp Where and what to lube it with
    Bullet 21xdc

  4. Electrical/Wiring/Trolling Motors Moderator Jonestrollingmotor's Avatar
    Join Date
    Jan 2005
    Location
    Texarkana
    Posts
    22,281
    #3
    Take the Ultrex off the mount and look at what is called the "links" (plastic side pieces that the steering module clips to). Also, while off, partially deploy the mount and see if you can twist the arm. If so, the pivot bushings are probably bad. These are like the Fortrex and located in the rear/pivot area of the mount, accessable by removing the side plates.
    John
    BBC Sponsor since 2006: (870) 773-3474
    Mon - Thrs 8am - 5pm Central
    Friday Closed, but accepting phone messages
    Talon Specials: Offering packages Call for quote and availability
    Click for website:

  5. Banned
    Join Date
    Mar 2011
    Location
    Lake Lanier
    Posts
    19,827
    #4
    all i heard was take it to a service center

  6. Member
    Join Date
    Nov 2016
    Location
    Thomson, Ga.
    Posts
    130
    #5
    Mine doing the same thing after only 5 or 6 fishing outings. My pivot bushings cannot be worn out. It is just one of those things that I put up with that is not perfect.
    Triton TR20X 225 Optimax
    Serial # 1B151269

  7. Banned
    Join Date
    Mar 2011
    Location
    Lake Lanier
    Posts
    19,827
    #6
    it only does it when the motor is turned when going over wakes but its annoying. gotta be something you can lube it with

  8. Member
    Join Date
    May 2013
    Location
    Ontario, Canada
    Posts
    2,704
    #7
    Men does the same, and it is not bushings. I used to use the dry WD40 for my Fortrex so it wouldn't drip all over, and I plan on trying it on my Ultrex.
    2015 Bass Cat P2

  9. Banned
    Join Date
    Mar 2011
    Location
    Lake Lanier
    Posts
    19,827
    #8
    fixed it by spraying it with wax as you dry

  10. Member
    Join Date
    Dec 2008
    Location
    MN.
    Posts
    168
    #9
    Quote Originally Posted by TroyBoy30 View Post
    fixed it by spraying it with wax as you dry
    where did you spray? Having the same issue.

  11. Banned
    Join Date
    Mar 2011
    Location
    Lake Lanier
    Posts
    19,827
    #10
    on the collor