Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Feb 2007
    Location
    Collinsville, IL
    Posts
    8,567

    Installing Rub Rail navigation lights

    I got a set of Blue Water Rub Rail Navigation lights. If I cut a section out of my rub rail the lights would be about 1 inset from the rub rail. I was thinking about shaving a flat spot in the rub rail then putting the nav light there so they will be flush with the rub rail. Is this how it is done normally?

  2.  
  3. Georgia Fishing Reports Moderator
    Join Date
    Jun 2004
    Location
    Rincon
    Posts
    10,977
    #2
    I had a new taco rub rail installed last year. When I recently got my set of led nav light strips I cut a hole in to fit the first strip. Like you said was not flush. But some small metal strips behind it for backer to get it flush. Used a clear sealant and SS screws to mount. The other side I used the double sided tape and the 2 screw and surface mounted it. Don't look bad and I am sure that I could have gotten it to look much better if I had prepare for the install better.

  4. Member CastingCall's Avatar
    Join Date
    May 2012
    Location
    MN
    Posts
    3,931
    #3
    Quote Originally Posted by STRETCH1 View Post
    I got a set of Blue Water Rub Rail Navigation lights. If I cut a section out of my rub rail the lights would be about 1 inset from the rub rail. I was thinking about shaving a flat spot in the rub rail then putting the nav light there so they will be flush with the rub rail. Is this how it is done normally?
    If you haven't installed them yet, post #10 on the attached post shows how I cut my rubrail insert, and used the cutout piece as a backer to mount the LEDs. Hope it helps.

    http://www.bbcboards.net/showthread.php?t=310131

  5. Member
    Join Date
    Feb 2007
    Location
    Collinsville, IL
    Posts
    8,567
    #4
    Quote Originally Posted by CastingCall View Post
    If you haven't installed them yet, post #10 on the attached post shows how I cut my rubrail insert, and used the cutout piece as a backer to mount the LEDs. Hope it helps.

    http://www.bbcboards.net/showthread.php?t=310131
    i haven’t mounted them yet, thanks for the tip.