Thread: 98 Cobra setup

Page 1 of 2 12 LastLast
Results 1 to 20 of 27
  1. #1
    Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84

    98 Cobra setup

    98Cobra 201,98 Johnson 225 Venom, 10' JACKPLATE. I Need motor height, prop and should i go 3 blade or 4 blade? Thanks for any help you guys can give me.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  2.  
  3. Pat Goff
    Join Date
    Jun 2004
    Location
    Smithwick/Seadrift TX
    Posts
    10,284
    #2
    25 Tempest with a bomb hub. Start at 3 3/4" and see how it runs.
    Pat Goff

    Two degrees from center
    of nowhere.
    Smithwick TX.

    [IMG][/IMG]

  4. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #3
    Thank u Mr Goff.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  5. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #4
    Mr Goff what exactly is a bomb hub?
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  6. Member
    Join Date
    Jan 2005
    Location
    hagerstown md
    Posts
    7,819
    #5
    Mercury hub kit for Evinrude or Johnson motor.

  7. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #6
    Thank you, Sir.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  8. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #7
    How would a 23p 4 blade ballistic fare on this setup. Iwill be ordering a tempest plus 25p anyways.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  9. Pat Goff
    Join Date
    Jun 2004
    Location
    Smithwick/Seadrift TX
    Posts
    10,284
    #8
    Not much hope.
    That hull wants all the bow lift it can get. That four blade won't give it.
    Pat Goff

    Two degrees from center
    of nowhere.
    Smithwick TX.

    [IMG][/IMG]

  10. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #9
    Great, thank you.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  11. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #10
    Mr Goff, i finally got a Tempest 25p. But im blowing out on launch. It has one plug missing. With the motor at 3.5 below pad.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  12. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #11
    Mr Goff, i finally got a Tempest 25p. But im blowing out on launch. It has one plug missing. With the motor at 3.5 below pad.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  13. Pat Goff
    Join Date
    Jun 2004
    Location
    Smithwick/Seadrift TX
    Posts
    10,284
    #12
    Quote Originally Posted by mastodon1977 View Post
    Mr Goff, i finally got a Tempest 25p. But im blowing out on launch. It has one plug missing. With the motor at 3.5 below pad.
    Review your setup.
    Nothing like a transducer blocking water flow?
    Do you have another plug? Duct tape works to test.
    Known good prop? Little bit of tip cup makes a difference.

    Or start dropping 1/4" at a time to find some bite. Johnrudes can't run as high as a merc.
    Pat Goff

    Two degrees from center
    of nowhere.
    Smithwick TX.

    [IMG][/IMG]

  14. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #13
    Hey Mr Goff, i installed some small plugs, now it will take off, but it takes forever for the RPM's to build up and the boat wheelies for a long time before its on plane.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  15. Member
    Join Date
    Aug 2011
    Location
    Boerne, Texas
    Posts
    8,839
    #14
    Do you have the plugs with the small holes in them or are they solid? What exactly do you have?

  16. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #15
    S, for small. It had 2 large and one plug missing.
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  17. Member
    Join Date
    Jan 2005
    Location
    hagerstown md
    Posts
    7,819
    #16
    If it bogging on take off which it sound like your doing it needs more venting on the blades. If you still have the large plugs that came with the prop put one of those back in it and try it again. Your trying to get between 3500 and 4000 rpm's at take off. They don't all have to be the same size either.

  18. Member
    Join Date
    Aug 2011
    Location
    Boerne, Texas
    Posts
    8,839
    #17
    Quote Originally Posted by mastodon1977 View Post
    S, for small. It had 2 large and one plug missing.
    Ok, so what was in the prop now? All 3 small or 2 large and a small? These guys need more exact details.

  19. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #18
    all 3 small right now. initially it had 2 large and one missing(open).
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  20. Member
    Join Date
    Jan 2008
    Location
    Del Rio
    Posts
    84
    #19
    Quote Originally Posted by mdtritn21 View Post
    If it bogging on take off which it sound like your doing it needs more venting on the blades. If you still have the large plugs that came with the prop put one of those back in it and try it again. Your trying to get between 3500 and 4000 rpm's at take off. They don't all have to be the same size either.
    You're 100% correct. Im going to try one large plug in combo w/ 2 small. Thank you....
    Mastodon1977
    1998 Cobra 201
    1998 Johnson 225HP Venom

  21. Member
    Join Date
    Aug 2011
    Location
    Boerne, Texas
    Posts
    8,839
    #20
    You're prob gonna need the 2 large and 1 small, but you never know.

Page 1 of 2 12 LastLast