Page 15 of 15 FirstFirst ... 5131415
Results 281 to 294 of 294
  1. Member
    Join Date
    Aug 2016
    Location
    Madison, al
    Posts
    185
    #281
    Quote Originally Posted by Thunderflight View Post

    Mine leaked at the gunnel top cap (sides and transom) dealer put a seam of silicone on it. Also check gas line fitting mine were lose and didn't hape any teflon tape on them.
    Thanks, Ive been pretty confined to the lake and smooth water so I'm baffled about where its leaking. i'm hoping the extra silicone on the transom helps. If not I guess i'll silicone the cap. I peeled some of the rub rail off yesterday to see how tight of a seal it is, and im kind of amazed it's not silicone backed from the factory.
    2017 Xpress H20B
    115 Yamaha SHO

  2. Member rocket man's Avatar
    Join Date
    Dec 2011
    Location
    chgo hts Il
    Posts
    1,132
    #282
    Could be from livewell if you fill to high. I had water coming up through the floor drains when I forgot to turn mine off. Bilge pump ran 1/2 hour.

  3. Member
    Join Date
    Aug 2016
    Location
    Madison, al
    Posts
    185
    #283
    Quote Originally Posted by rocket man View Post
    Could be from livewell if you fill to high. I had water coming up through the floor drains when I forgot to turn mine off. Bilge pump ran 1/2 hour.
    I don't really use the livewell. I just catch and release. If silicone on the top cap doesn't fix it, i'm going to look into that tubing though. I kind of wonder if one of the connections from the livewell system that leads out the transom are loose. I checked one or two and they seemed tight enough. i'll check it out more when I get home from work. i shouldn't be too concerned about the gallon or two, but i go to the Chesapeake bay two or three times a year and don't want salt water sitting in the bilge anymore than i have to, especially if i keep it in the water for a few days.
    2017 Xpress H20B
    115 Yamaha SHO

  4. Member Thunderflight's Avatar
    Join Date
    Jan 2014
    Location
    Newport, NC
    Posts
    77
    #284
    Bring it back to dealer and have them fix it. The water coming up on sides of mine ripped off the express plastic decals. I made them send me new ones but decided to leave them off.
    Thunderflight
    2015
    Xpress H20 Bay
    F150LB Yamaha
    Pro High Jacker ZLock manual 6 in jackplate 5.5 prop to pad
    Power Tech OFX 21 50 mph
    MinnKota 70 Edge
    Lowrance HDS-7 Touch/Samsung 10 inch tablet/GoFree Wifi/Ram mounting systems
    NOCO Gen 3 3 bank charger

    SEMPER FI

  5. Member
    Join Date
    Aug 2016
    Location
    Madison, al
    Posts
    185
    #285
    Quote Originally Posted by Thunderflight View Post
    Bring it back to dealer and have them fix it. The water coming up on sides of mine ripped off the express plastic decals. I made them send me new ones but decided to leave them off.
    Haha I would but he's three hours away. I'd burn more in gas than i'd spend for a couple of tubes of silicone. I'm taking it out Saturday to see if what I have done has fixed it.
    2017 Xpress H20B
    115 Yamaha SHO

  6. Member Thunderflight's Avatar
    Join Date
    Jan 2014
    Location
    Newport, NC
    Posts
    77
    #286
    Make sure you check the cap on the transom, it has a gap too.
    Thunderflight
    2015
    Xpress H20 Bay
    F150LB Yamaha
    Pro High Jacker ZLock manual 6 in jackplate 5.5 prop to pad
    Power Tech OFX 21 50 mph
    MinnKota 70 Edge
    Lowrance HDS-7 Touch/Samsung 10 inch tablet/GoFree Wifi/Ram mounting systems
    NOCO Gen 3 3 bank charger

    SEMPER FI

  7. Member
    Join Date
    Jul 2016
    Location
    Auburn, AL
    Posts
    4
    #287
    I have a H20B and am wondering about where you tie off your anchor rope. My frontmost cleat is nearly even with the front deck seat. Did anyone install another cleat on the bow next to the trolling motor and if so, what type?

    I also want to install 4 to 6 LEDs around the inside edge; where did you run the wires?

    Thanks

  8. Member
    Join Date
    Aug 2016
    Location
    Madison, al
    Posts
    185
    #288
    Quote Originally Posted by edwardo43 View Post
    I have a H20B and am wondering about where you tie off your anchor rope. My frontmost cleat is nearly even with the front deck seat. Did anyone install another cleat on the bow next to the trolling motor and if so, what type?

    I also want to install 4 to 6 LEDs around the inside edge; where did you run the wires?

    Thanks
    I just clip my anchor to the eye on the front of the bow.
    2017 Xpress H20B
    115 Yamaha SHO

  9. Member
    Join Date
    Jul 2016
    Location
    Auburn, AL
    Posts
    4
    #289
    Thats a long way to reach to tie off an anchor rope, especially for a short man.

  10. Member
    Join Date
    Mar 2016
    Location
    north texas
    Posts
    3
    #290
    Under gunnell lights i used came from academy,bout 2 foot long, dual color,white and blue.very happy. Mounted 2 at rear and 2 up front. Fish wire from bildge up and through the end caps, (port side is where ladder mounts, strbd has stern light) right where the inboard cap meets the side of the hull,coming forward,you will see a small gap.run wires through a small piece of tubing here so there will be no chafeing. Probly pretty tight.put a little goop on back of the light bar and stick it under gunnel facing down and against the hull wall. While youre there and knuckles are bleedin you could go ahead and drill the hole for your watertite battery charger plug and run those wires. fish wires to helm. Remember to use a dual position switch for two colors. Since you gotta run a wire up front,go ahead and plan your storage and rod box lights and run wire and buy a switch for those.( White light bars). That same gap you used on the rear exists on the front,right at the point wherethe front cap meets the gunnell. Fasten bar under gunnel as before. Mounted this way, the lights are inderict illumination. A nd will light your world. You could run green lights on the outside the same way. Hope i laid this out so it makes sense.let me know if you need pics.ill need help with that. I can help you with the routing of the stotage lite wires when your ready,that was tricky. My h20b has light in every box an access,including livewells, mods and personel touches everywhere.id be happy to share what works great and what id do different.

  11. Member
    Join Date
    Aug 2016
    Location
    Madison, al
    Posts
    185
    #291
    Quote Originally Posted by lead chunker View Post
    Under gunnell lights i used came from academy,bout 2 foot long, dual color,white and blue.very happy. Mounted 2 at rear and 2 up front. Fish wire from bildge up and through the end caps, (port side is where ladder mounts, strbd has stern light) right where the inboard cap meets the side of the hull,coming forward,you will see a small gap.run wires through a small piece of tubing here so there will be no chafeing. Probly pretty tight.put a little goop on back of the light bar and stick it under gunnel facing down and against the hull wall. While youre there and knuckles are bleedin you could go ahead and drill the hole for your watertite battery charger plug and run those wires. fish wires to helm. Remember to use a dual position switch for two colors. Since you gotta run a wire up front,go ahead and plan your storage and rod box lights and run wire and buy a switch for those.( White light bars). That same gap you used on the rear exists on the front,right at the point wherethe front cap meets the gunnell. Fasten bar under gunnel as before. Mounted this way, the lights are inderict illumination. A nd will light your world. You could run green lights on the outside the same way. Hope i laid this out so it makes sense.let me know if you need pics.ill need help with that. I can help you with the routing of the stotage lite wires when your ready,that was tricky. My h20b has light in every box an access,including livewells, mods and personel touches everywhere.id be happy to share what works great and what id do different.
    Can you post a few pics when you get a chance? I've been contemplating the same thing on my boat.
    2017 Xpress H20B
    115 Yamaha SHO

  12. Member
    Join Date
    Mar 2016
    Location
    north texas
    Posts
    3
    #292
    Quote Originally Posted by The gurg View Post
    Can you post a few pics when you get a chance? I've been contemplating the same thing on my boat.
    Sure thing, trying to figure that part out now

  13. Member
    Join Date
    Mar 2016
    Location
    north texas
    Posts
    3
    #293
    Last edited by lead chunker; 01-13-2017 at 07:10 PM.

  14. Member
    Join Date
    Aug 2016
    Location
    Madison, al
    Posts
    185
    #294
    Quote Originally Posted by lead chunker View Post
    looks really clean! i'm going to look into doing it on mine. thanks!
    2017 Xpress H20B
    115 Yamaha SHO

Page 15 of 15 FirstFirst ... 5131415