Page 3 of 5 FirstFirst 12345 LastLast
Results 41 to 60 of 96
  1. Electrical/Wiring/Trolling Motors Moderator Jonestrollingmotor's Avatar
    Join Date
    Jan 2005
    Location
    Texarkana
    Posts
    20,936
    #41

    Re: (08 198 Champ)

    Sorry, thought I answered this yesterday -- but that shows what a 50+ memory is like

    I would be cautious of the the "front" battery. In the "charge" world of batteries, .14V makes a lot of difference. As stated before, the eye or indicator is just for that cell that it is above, but if it showing red, it can mean that cell is marginal or bad. The one showing black, could have a bad cell other than the one the indicator is on, but in this case, the voltages for it look good.
    Hope this helps, John
    BBC Sponsor http://www.jonestrollingmotor.com (870) 773-3474
    Mon - Thrs 8am - 5pm Friday 8am -12pm Central time
    Talon Specials: Call for quote and availability

  2. Member
    Join Date
    Aug 2004
    Location
    West Bend, WI
    Posts
    7,690
    #42

    Re: (Jonestrollingmotor)

    <table width="90%" cellspacing=0 cellpadding=0 align=center><tr><td>Quote, originally posted by Jonestrollingmotor &raquo;</td></tr><tr><td class="quote">Sorry, thought I answered this yesterday -- but that shows what a 50+ memory is like

    I would be cautious of the the "front" battery. In the "charge" world of batteries, .14V makes a lot of difference. As stated before, the eye or indicator is just for that cell that it is above, but if it showing red, it can mean that cell is marginal or bad. The one showing black, could have a bad cell other than the one the indicator is on, but in this case, the voltages for it look good.
    Hope this helps, John
    </td></tr></table>

    Thanks for the reply. I need to run the test again with charging the batteries. I don't think I drained the front battery enough when I charged it and recorded the reading. The 14.33 was right before the charger went to maintain and it still was climbing. Thanks again for the infor.....much appreciated Have a good weekend.
    2012 Ranger Z520 DC / 250 Pro XS

  3. Member
    Join Date
    Mar 2008
    Location
    laredo
    Posts
    4
    #43

    Re: MinnKota Battery Chargers/Light readout (Jonestrollingmotor)




    Modified by southtex at 9:21 AM 12/6/2011

  4. Member
    Join Date
    Jul 2011
    Location
    Dirty Jerzy
    Posts
    198
    #44

    Re: MinnKota Battery Chargers/Light readout (carl gagnon)

    Had the same problem. Sent it to minn kota the checked it and said it was bad. Because I purchased it within 3 yrs of it going bad they sent me a new one no questions asked. It is even the updated mk330d model. Great company!!!

  5. Member
    Join Date
    Feb 2012
    Location
    Morris
    Posts
    1
    #45

    Re: MinnKota Battery Chargers/Light readout (hosko n ky)

    Did you discover ant trick to opening those yellow fuse connectors? I can't get any of mine open.

  6. #46

    Re: MinnKota Battery Chargers/Light readout (cmcmcm123)

    Never mind, found it, batteries totally dead! New Dekas last year, too! Darn it! Starter battery fine, 3 other boats in the pole barn and all are fine, but not my TM batts!!! Think they're covered?

    &lt;br /&gt;&lt;br /&gt;
    Modified by RedBlazer at 4:54 PM 2/26/2012


    Modified by RedBlazer at 4:56 PM 2/26/2012
    Doug
    10\' Z8 w/225 ProXS

  7. Member
    Join Date
    Jun 2004
    Location
    Kuttawa, KY
    Posts
    2,785
    #47

    Re: MinnKota Battery Chargers/Light readout (cmcmcm123)

    <table width="90%" cellspacing=0 cellpadding=0 align=center><tr><td>Quote, originally posted by cmcmcm123 &raquo;</td></tr><tr><td class="quote">Did you discover ant trick to opening those yellow fuse connectors? I can't get any of mine open.</td></tr></table>
    Same here! Any suggestions?

  8. Member
    Join Date
    Jun 2004
    Location
    Kuttawa, KY
    Posts
    2,785
    #48

    Re: MinnKota Battery Chargers/Light readout (GM482V)

    Got it. Mine just pull apart.

  9. Member
    Join Date
    Aug 2006
    Location
    Bentonville, AR
    Posts
    44
    #49
    Here's a good one mk330d - Every other time I plug it in after fishing the second bank does not change from all three lights being lit. Unplug it and plug in with no change several times then poof it goes to yellow and starts to charge. After it has charged a few seconds unplug, plug it back in and continues to work good. Switch batteries,still second bank....... Looked everywhere and couldn't find this problem.. Ideas? Thanks

  10. Electrical/Wiring/Trolling Motors Moderator Jonestrollingmotor's Avatar
    Join Date
    Jan 2005
    Location
    Texarkana
    Posts
    20,936
    #50
    If you switched batteries, and still happened on the second bank, it may have a temp sensor in the leads damaged or going bad. How old is the charger?
    BBC Sponsor http://www.jonestrollingmotor.com (870) 773-3474
    Mon - Thrs 8am - 5pm Friday 8am -12pm Central time
    Talon Specials: Call for quote and availability

  11. Member
    Join Date
    Aug 2006
    Location
    Bentonville, AR
    Posts
    44
    #51
    Quote Originally Posted by Jonestrollingmotor View Post
    If you switched batteries, and still happened on the second bank, it may have a temp sensor in the leads damaged or going bad. How old is the charger?
    2 yrs but I thought damaged temp sensor showed red and green only? This keeps all lit up........ Intermittently! Have you ever seen that?

  12. Electrical/Wiring/Trolling Motors Moderator Jonestrollingmotor's Avatar
    Join Date
    Jan 2005
    Location
    Texarkana
    Posts
    20,936
    #52
    On the "D" chargers:
    Plugging in all lights come on monetarily while "reading" the batteries
    Yellow: Bulk charge mode til battery reaches 75% of charge
    Flashing Yellow: Absorption Mode, charging current tapers holding battery to 14.4V apx
    Flashing Green : Maintenance mode, voltage goes to 13.4V
    Green: Charger turns itself off after 24hrs and monitors battery
    When battery voltage drops below 12.6V, charger will turn back on

    Sounds like with all lights staying on, bank isn't reading the battery initially for some reason. The charger is warrantied for 3yrs. I would call MinnKota and explain. I'm guessing they will send you a RA and and new charger.
    John
    BBC Sponsor http://www.jonestrollingmotor.com (870) 773-3474
    Mon - Thrs 8am - 5pm Friday 8am -12pm Central time
    Talon Specials: Call for quote and availability

  13. Member
    Join Date
    Apr 2009
    Location
    Rice Lake, WI
    Posts
    146
    #53
    Having a strange problem with my 3 bank minn Kota charger...

    When one of the banks is plugged in it just goes to green, it skips the charging light completely. I just fished a tournament today and my batteries obviously need charging... So I switched the banks out on two of my batteries and it's the charger, not the batteries. Any clue on why the bank would say the battery is charged when it isn't? Would it be in the yellow fuse holders possibly?

  14. Banned
    Join Date
    Jan 2010
    Posts
    6,141
    #54
    I have a MK345D 3 bank charger. I connected the charger up and it has charged at least 12 hours checking. All 3 banks had blinking green lights except #3 bank had blinking red light. Check connection. I unplugged charger removed the #3 bank connections cleaned all contacts and post on battery. Reconnected bank #3 and reconnected power to charger. #1, #2, banks all returned to the flashing green lights except #3 bank it has stayed yellow. With the charger off I checked battery voltage at #1, and #2 to be 13.45V #3 at 12.45V. I checked fuses(30A) to be good but replaced them anyway. I checked Charger's output voltage of #3 bank leads to be 14.V but when connected to battery it read battery voltage 12.6V. I reconnected charger to batteries, #1bank starting, #2 bank & #3 bank trolling motor. The #1 bank & #2 bank checked to have, 14.56V and the #3 bank checked to have 12.56V. Both trolling motor batteries are new. I changed #3 and #2 leads and see if there is a difference. The #3 bank stayed yellow. I then returned #3 battery for brand new battery and reattached charger leads to proper positions. Still yellow light on #3 bank. My guess #3 bank on the charger has a concern. I let it charge about 5 hours now the green light is blinking on and also red light is blinking.
    Last edited by XSDRD; 06-22-2013 at 09:14 PM.

  15. Electrical/Wiring/Trolling Motors Moderator Jonestrollingmotor's Avatar
    Join Date
    Jan 2005
    Location
    Texarkana
    Posts
    20,936
    #55
    Sounds like it may be a charger issue. How old is the charger?
    BBC Sponsor http://www.jonestrollingmotor.com (870) 773-3474
    Mon - Thrs 8am - 5pm Friday 8am -12pm Central time
    Talon Specials: Call for quote and availability

  16. Banned
    Join Date
    Jan 2010
    Posts
    6,141
    #56
    I bought the unit 6/18/2012. I talked to Minnkota this afternoon and they are sending me a new one and when it gets here I will return the old one and hopefully that will take of that.

  17. Member
    Join Date
    Dec 2011
    Location
    South Louisiana
    Posts
    58
    #57
    I am on my second MK330D charger in my Skeeter. The first unit started showing a flashing red and green light on bank 2. Switched the leads on battery one and two and problem remained with bank two. Contacted Minn Kota and they sent me another charger. Had the battery checked and it checked good. I have three Optima Blue Top batteries which are about 1 1/2 years old.

    New changer which is abut three months old is doing the exact same thing. Bank two shows red and green flashing lights and when the leads are switched, the problem remains with bank two.

    Any ideas, it appears a lot of people are having issue with these particular chargers. I keep my charger plugged in at all times...could this be causing a problem as well?

    Thanks in advance!

  18. Member
    Join Date
    Nov 2012
    Location
    Cadiz, KY
    Posts
    154
    #58
    I just bought my first Minnkota 330d charger. I have a 2006 Triton TR 21X and will be mounting next to the cranking battery. What is the biggest size screw I can use to mount the charger with?

  19. Member
    Join Date
    Apr 2012
    Location
    Macomb, Il.
    Posts
    6
    #59
    I have a minnkota 4 bank charger in my 2011 skeeter fx20. is it possible for the charger to short circuit a battery or fry it? on the # 3 bank I have had to replace the battery 3 times in 3 weeks. plug boat in and other batteries charge fine. bank #3 battery will show charging light for a while then go red. took batteries to get tested and all 3 were shot. have tried optimas and duracells and got same results. any ideas?

  20. Electrical/Wiring/Trolling Motors Moderator Jonestrollingmotor's Avatar
    Join Date
    Jan 2005
    Location
    Texarkana
    Posts
    20,936
    #60
    Usually a charger won't fry a battery, but this sounds suspicious. I would monitor the charge voltage with a voltmeter on that bank til you get the issue resolved.
    John
    BBC Sponsor http://www.jonestrollingmotor.com (870) 773-3474
    Mon - Thrs 8am - 5pm Friday 8am -12pm Central time
    Talon Specials: Call for quote and availability

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Battery Chargers
    By Charlie206 in forum Texas Bass Club
    Replies: 20
    Last Post: 05-23-2011, 04:41 AM
  2. MinnKota Digital Chargers Video Clip
    By Doug Vahrenberg in forum Electrical/Wiring/Trolling Motors
    Replies: 0
    Last Post: 03-21-2011, 07:51 PM
  3. Minnkota MK-440D chargers
    By smworker1 in forum Electrical/Wiring/Trolling Motors
    Replies: 3
    Last Post: 02-20-2011, 05:18 AM
  4. MinnKota Digital On-Board Chargers - Website Info Updated
    By Doug Vahrenberg in forum Electrical/Wiring/Trolling Motors
    Replies: 0
    Last Post: 11-23-2010, 02:25 PM
  5. battery chargers??????
    By Texas Xpress in forum Novice Boaters Forum
    Replies: 14
    Last Post: 03-09-2008, 08:30 AM