Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Jul 2013
    Location
    Indianapolis Indiana
    Posts
    604

    Power pole stuck down

    I have had these 8 blades for 3 years. Today was last trip of the year. Came back to ramp and put pp down almost all the way. Put trailer in but when I went put the boat on the 1 pp stuck in the full down position. Drove boat to shallow water still stuck. Got next to dock and 2 of us wrapped a rope around it pulled as nard as we could. Nothing. Pump was making noise for awhile the I think a fuse blew because green light on pump went out. Had to take off lines then pulled up easily. Toed off and went home. Now I need to call pp for a fix. Is was a real pain in the butt tieing up the ramp for 40 minutes.

  2. Member
    Join Date
    Jul 2013
    Location
    Indianapolis Indiana
    Posts
    604
    #2
    Talked to JL. They are not sure what would cause the problem. When in doubt pull the pumps and send back for a complete check.

  3. Member 06 SB's Avatar
    Join Date
    Feb 2012
    Location
    West Point Lake, GA
    Posts
    8,196
    #3
    Blades have a pressure relief valve and all you have to do is manually push it back up. It pushes all the fluid back into the reservoir and the pole goes limp. It takes some grunt but I can do it myself and have had to do it several times when moving pumps or rearranging a bilge compartment for someone.
    Last edited by 06 SB; 12-01-2020 at 08:01 PM.

    USN Retired
    2020 Basscat Caracal
    2020 Mercury 225 ProXS 4s



  4. Member
    Join Date
    Jun 2006
    Location
    DeLand, FL
    Posts
    342
    #4
    Quote Originally Posted by bassm1n View Post
    I have had these 8’ blades for 3 years. Today was last trip of the year. Came back to ramp and put pp down almost all the way. Put trailer in but when I went put the boat on the 1 pp stuck in the full down position. Drove boat to shallow water still stuck. Got next to dock and 2 of us wrapped a rope around it pulled as nard as we could. Nothing. Pump was making noise for awhile the I think a fuse blew because green light on pump went out. Had to take off lines then pulled up easily. Toed off and went home. Now I need to call pp for a fix. Is was a real pain in the butt tieing up the ramp for 40 minutes.
    ask them if you can do a diagnostic test via the app...maybe they can spot the problem...worked for me
    Alweld 1856 Stick Steer with 70 Yamaha
    Dual Power Pole Blades/ Helix 10 MSI
    80# Ulterra Link/2 Ionic Lithium 50s/ShuttleSlide Mount

    USAF Ret

  5. Member
    Join Date
    Jul 2020
    Location
    Tampa, FL
    Posts
    5
    #5
    OP - Sorry to hear of the unfortunate event of the Power-Pole(s) being stuck down. I'm glad one of the members is currently assisting you. If you need any additional help, please PM your contact info.

    The pressure relief valve only works when that Power-Poles are going up(retracting); you can assist in helping the units by DRIVING FORWARD, while trying to retract the unit(s) with the remote or dash switch. If this does not work, you can manually retract the units with dockline or pushing the units UP. Severe damage can be caused to the Power-Pole(s) if you reverse/backover them in the deployed(down/anchored) position.