Results 1 to 15 of 15
  1. #1
    Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706

    Motor just shuts off G2

    My 2017 175 hp G2 just shuts off. I had the ignition switch changed (3rd one now)and now it will just randomly shut down. I had the dealer install another one(4th one) and it still randomly shuts down. Never happened until the new upgraded switches were installed. No codes, just shuts down. Always starts right back up tho. Any thoughts?
    Pool 10

  2.  
  3. Member
    Join Date
    Aug 2015
    Location
    New Bedford,MA
    Posts
    1,545
    #2
    Would suck at WOT
    Mike
    2019 520L w/ 250HO ETEC G2

  4. Ranger Boats Moderator jc2bg's Avatar
    Join Date
    Sep 2009
    Location
    Findlay, Ohio
    Posts
    8,521
    #3
    Are you sure you got the upgraded [latest upgrade, since October 2018] switch? Behind the panel where the switch is, the newest/upgrade switch is shrouded in silver-gray. The previous switch had a black shroud over the wires. Other than that, if you have the newest/latest key switch, there’s an electrical short somewhere. Above my pay grade, too.

  5. Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706
    #4
    Yes, I checked and it has the grey sleeve. It flash a code today for a split second. I think it was either code 150 or 180, not sure tho as it just flashed for a second. Does anyone know what 150 or 180 could be?
    Pool 10

  6. Member Danrude's Avatar
    Join Date
    Apr 2007
    Location
    Marietta, GA
    Posts
    3,254
    #5
    180 ETC running effort fault - The throttle plate requires too much effort to move. Engine is limited to 1200 RPM. Check for foreign object in throttle body.
    Dan Burnette - Marietta, GA
    Triton 18TRX - 200 HO G2

  7. Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706
    #6
    Finally stayed on long enough to read it today. Dan rude you nailed it. But it is not limited to 1200 rpms, it just shuts off
    How do I check for foreign object in throttle body?
    180 ETC
    running effort
    Last edited by Mc Gregor; 08-23-2019 at 04:16 PM.
    Pool 10

  8. Moderator SEAHORSE's Avatar
    Join Date
    Jun 2004
    Posts
    9,159
    #7
    It could be one of the plastic covers in the air channels.

    G2 plastic plug locations in top cover.JPG
    -----


    A Technical troubleshooter possessing more tools than talent !

  9. Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706
    #8
    plugs are in, but thanks for the input seahorse
    Pool 10

  10. Moderator SEAHORSE's Avatar
    Join Date
    Jun 2004
    Posts
    9,159
    #9
    Quote Originally Posted by Mc Gregor View Post
    plugs are in, but thanks for the input seahorse
    Did you remove the top large diameter one to inspect the one below it?
    -----


    A Technical troubleshooter possessing more tools than talent !

  11. Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706
    #10
    Yes
    Pool 10

  12. Member
    Join Date
    Jun 2016
    Location
    Houston, TX
    Posts
    350
    #11
    You can temporarily unplug the fuel sender wires from the controller and see if problem goes away. Ive seen cases were EMI was being introduced into the system from the fuel level circuit and causing random shut down.

    Other then that the next thing for the dealer to try would be to try swapping out control head and harness.

    When a key switch does not fix random shut downs it can be a real PITA to track down.

  13. Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706
    #12
    I am not a gear head and have no clue as to where the fuel sender wires are. Are they very easy to locate? Appreciate you’re help 57
    Pool 10

  14. Member
    Join Date
    Jun 2016
    Location
    Houston, TX
    Posts
    350
    #13
    The controller installed in the side of the boat has about 12 leads with different plugs coming off of it, they are all labeled. 4 of those leads are fluid level converters for fuel tanks and other fluid tanks such as auxiliary oil tanks. Unplug any of those that are connected and see if the problem goes away.

  15. Member
    Join Date
    Oct 2004
    Location
    Beaver Dam, WI
    Posts
    445
    #14
    Any other electronics running or activated when this happens? We had an issue with RFI spiking the throttle position percentage to 135% and engine would shut off. Had to relocate two way radio away from the control head.

  16. Member
    Join Date
    Dec 2011
    Location
    Pool 10
    Posts
    706
    #15
    Just my Lowrance HDS 9, but it has been there since day 1
    Pool 10