Results 1 to 10 of 10
  1. #1
    Member
    Join Date
    Jan 2012
    Location
    Whitesburg
    Posts
    138

    2003 mercury 225 efi numerous alarms

    Fishing tourney yesterday and everything was great made 2 long runs on cherokee lake from Gilmore to dam then dam to 25e. Prob 7 miles first run and 12 miles second. Fished for a while after 2nd run and then decided to move... Boat made three broken alarm beeps about every 15 sec. Kept turning off and back on and continued. Then it would do it with just the key turned on. After about 15 mins of trying to limp back to Gilmore starting and stoping to give it a break it became a steady alarm... Oil res is full in engine... Water was shooting out of pisser... Nothing seemed any different than any other day...

    Any thoughts???

  2.  
  3. Mercury - 3 Liter Moderator EuropeanAM's Avatar
    Join Date
    Apr 2008
    Location
    Greenville, SC (US)
    Posts
    55,035
    #2

    Re: 2003 mercury 225 efi numerous alarms (chancey021)

    Appropriate means of finding the cause it to get the engine on the Computer Diagnostic System for PRINTOUTS of:

    -Run History
    -Freeze Frame (Fault) History

    Information in these reports will result in an appropriate diagnosis, and a successful cure.

    Did you dump the contents of the fuel filter into a glass jar to inspect for WATER separating out???




    Dual Mercury Master Technician- for Mercury Outboards, Racing & Mercruiser Sterndrives in Greenville, SC.
    Still consider myself a "Marine Apprentice" after 38 years (learn something new every day).
    Mercury Parts, Mercury Outboards, Smartcraft & Accessories, Injector Service, TDR Reeds- BBC Sponsor

  4. Member
    Join Date
    Jan 2012
    Location
    Whitesburg
    Posts
    138
    #3

    Re: 2003 mercury 225 efi numerous alarms (EuropeanAM)

    I did not do the fuel filter thing...

    Do you recommend any certain shop in the east ky east Tennessee area? I bought the boat less than 2 months ago... Did have it checked out when I bought it... Maybe went to wrong shop

  5. Mercury - 3 Liter Moderator EuropeanAM's Avatar
    Join Date
    Apr 2008
    Location
    Greenville, SC (US)
    Posts
    55,035
    #4

    Re: 2003 mercury 225 efi numerous alarms (chancey021)

    Try this link:

    http://www.mercurymarine.com/find-a-dealer

    Under Outboard Service, choose "Premier".




    Dual Mercury Master Technician- for Mercury Outboards, Racing & Mercruiser Sterndrives in Greenville, SC.
    Still consider myself a "Marine Apprentice" after 38 years (learn something new every day).
    Mercury Parts, Mercury Outboards, Smartcraft & Accessories, Injector Service, TDR Reeds- BBC Sponsor

  6. Member
    Join Date
    Jan 2012
    Location
    Whitesburg
    Posts
    138
    #5

    Re: 2003 mercury 225 efi numerous alarms (EuropeanAM)

    I took it to a local guy at a marina before u sent that last message...

    He put it on a computer and said it ran low on oil for 6027 seconds and that it was showing over heat code on starboard side...

    Your thoughts???

    He wants to disconnect the oil mixer and have me start mixing my own straight in gas tank...

    Then said he is going to take on water and thinks it may need a thermostat...

  7. Mercury - 3 Liter Moderator EuropeanAM's Avatar
    Join Date
    Apr 2008
    Location
    Greenville, SC (US)
    Posts
    55,035
    #6

    Re: 2003 mercury 225 efi numerous alarms (chancey021)

    1. DO NOT let anyone talk you into disabling the oil injection on this model. Depending on your serial number.... it may not even be safely POSSIBLE.

    2. Any time overheating problems are occurring, you should ALWAYS, ALWAYS start at the SOURCE: The Water Pump.

    ONLY after water pump has been COMPLETELY REPLACED (and problems persist), is it appropriate to move on to other potential causes (thermostats, poppet valve, gaskets, restrictions, etc).




    Dual Mercury Master Technician- for Mercury Outboards, Racing & Mercruiser Sterndrives in Greenville, SC.
    Still consider myself a "Marine Apprentice" after 38 years (learn something new every day).
    Mercury Parts, Mercury Outboards, Smartcraft & Accessories, Injector Service, TDR Reeds- BBC Sponsor

  8. Member
    Join Date
    Jan 2012
    Location
    Whitesburg
    Posts
    138
    #7

    Re: 2003 mercury 225 efi numerous alarms (EuropeanAM)

    Here is what is being done now...

    He checked compression and it was 105-115 on all

    He said it needs the oil pump on right side and he is putting a water pump in it at my request... Boat has not had water pump changed in at leaste 4yrs.


  9. Mercury - 3 Liter Moderator EuropeanAM's Avatar
    Join Date
    Apr 2008
    Location
    Greenville, SC (US)
    Posts
    55,035
    #8

    Re: 2003 mercury 225 efi numerous alarms (chancey021)

    Good move.

    Be sure to report back with results.




    Dual Mercury Master Technician- for Mercury Outboards, Racing & Mercruiser Sterndrives in Greenville, SC.
    Still consider myself a "Marine Apprentice" after 38 years (learn something new every day).
    Mercury Parts, Mercury Outboards, Smartcraft & Accessories, Injector Service, TDR Reeds- BBC Sponsor

  10. Member
    Join Date
    Jan 2012
    Location
    Whitesburg
    Posts
    138
    #9
    VERY FRUSTRATED!!!!

    Boat has been in shop since march 27th... after new oil pump, hoses, and some kind of valve... new problems that were not there have popped up

    5 sensors are showing to be bad.. fuel, c-temp, trim sensor, high fuel sensor, and low oil sensor!!!

    and my motor swings freely back and forth while driving... I know this because when I went to check on my boat that has been there forever... the guy was working on someone elses... and I had authorized him to just find the problem... so $605.00 later I have more issues than what I dropped it off with and his only responce was when you figure out what was wrong let me know!!!! Really!!!!

    Awesome Day!!!!

  11. Mercury - 3 Liter Moderator EuropeanAM's Avatar
    Join Date
    Apr 2008
    Location
    Greenville, SC (US)
    Posts
    55,035
    #10
    Quote Originally Posted by chancey021 View Post
    5 sensors are showing to be bad.. fuel, c-temp, trim sensor, high fuel sensor, and low oil sensor!!!
    Your technician should be FULLY AWARE that the sensors listed above are "Ghost Faults". Essentially, they are OPTIONAL sensors, and likely you do not have them (hence the PCM is looking for them on the system, and reporting them as faults). None of the above sensor faults should cause a warning horn. If this concept seems confusing to your tech.... make a CHANGE.

    Note on "oil sensor": There are several possible faults (your wordings aren't exactly matching any of them). Precise PRINTOUTS of the faults would allow for accurate determination of which ones are, or are not something to be concerned about.

    As for the steering.... sounds like there's air in the system.


    Dual Mercury Master Technician- for Mercury Outboards, Racing & Mercruiser Sterndrives in Greenville, SC.
    Still consider myself a "Marine Apprentice" after 38 years (learn something new every day).
    Mercury Parts, Mercury Outboards, Smartcraft & Accessories, Injector Service, TDR Reeds- BBC Sponsor

Similar Threads

  1. '96 Mercury 225 alarms flashing and buzzing
    By Champion88 in forum Mercury - 3 Liter & 3 Liter High Performance
    Replies: 11
    Last Post: 03-24-2012, 09:13 AM
  2. 2003 Mercury 200 EFI - 2.5 Liter
    By Swampland in forum Motors
    Replies: 2
    Last Post: 03-18-2012, 03:26 PM
  3. 2003 200 MERCURY EFI
    By 200320xd in forum Motors
    Replies: 8
    Last Post: 03-13-2012, 02:36 PM
  4. 2003 Mercury 200 EFI
    By Gamblerman02 in forum Mercury - 3 Liter & 3 Liter High Performance
    Replies: 1
    Last Post: 09-12-2009, 07:58 AM
  5. 2003 mercury efi
    By gastongambler in forum Mercury - 3 Liter & 3 Liter High Performance
    Replies: 4
    Last Post: 05-01-2009, 06:58 AM