Results 1 to 3 of 3
  1. #1
    Member cart7's Avatar
    Join Date
    Sep 2004
    Location
    Arnold, missouri
    Posts
    2,949

    Weird problem when fueling boat.

    I posted this in the General forum, thought I'd post it here too.


    I've got a 184 DC that's got an odd problem when fueling through the fuel fill spout on the outside of the boat. Let me preface this by saying the fuel inlet and vent line attachments on the tank itself are right next to each other.

    Whenever I fuel, even if the tank is nearly empty like Friday evening, I get fuel coming back out the vent line if I try and fill at any speed other than a slow trickle. I can hear the fuel trying to come back out the vent outlet and it actually spits and trickles as I'm fueling. Again, the tank is nearly empty. How is this happening and what can I do to stop it? I've owned several boats before and never experienced this.

  2.  
  3. Member Skip's Avatar
    Join Date
    Jun 2004
    Location
    Hewitt, Texas
    Posts
    19,098
    #2

    Re: Weird problem when fueling boat. (cart7)

    We jbought a '05 188 a few month's ago and our's ffed's back also. What I do is hold the gas spout upside down and gas very slowly. It's the easiest way to solve the problem. You just have to be patient.

  4. Member
    Join Date
    Jan 2005
    Location
    Odessa Tx / Ragley La
    Posts
    7,006
    #3

    Re: Weird problem when fueling boat. (Skip)

    What Skip said, it is worse the less gas you have in the tank due to more air in it.

Similar Threads

  1. still having weird problem
    By swampratwt in forum Mercury - 2.0/ 2.4/ 2.5 Liter High Performance
    Replies: 1
    Last Post: 06-15-2011, 01:15 PM
  2. Weird Problem
    By TritonMJM in forum Trailers & Towing
    Replies: 4
    Last Post: 01-19-2010, 07:49 AM
  3. Fueling The Boat
    By Lpolk in forum Champion Boats
    Replies: 4
    Last Post: 11-10-2008, 05:08 AM
  4. Fueling problem
    By bayboater in forum Skeeter Boats
    Replies: 24
    Last Post: 02-11-2008, 08:11 AM
  5. Weird E-Tec problem..........please help!
    By Byrdseye in forum Evinrude/Johnson Motors
    Replies: 21
    Last Post: 09-04-2006, 08:24 AM